Algunos iPhone, iPad, iPod y Apple TV antiguos podrían verse afectados por el fallo de seguridad de los procesadores

iPhone 4S

Como probablemente ya sabrás, recientemente se ha descubierto una nueva amenaza de seguridad que permite acceder a datos privados de la memoria de los dispositivos — como contraseñas o claves de acceso — a través de una vulnerabilidad CPU.

Aunque inicialmente se pensaba que solo iba a afectar a los procesadores de la popular firma Intel, tal y como explicó ayer Google y confirmó Intel hace unas horas, la amenaza no solo afecta a los procesadores de Intel, sino también a los de cualquier otra firma.

Debido a esto, desde ARM han lanzado una investigación, y en ella se ha determinado que algunos de los procesadores que se basan en su arquitectura también son vulnerables a este fallo de seguridad. Por esto mismo, han lanzado una actualización en la que determinan que, entre otros, los procesadores con Cortex-A8, Cortex-A9 y Cortex-A15 son vulnerables

Como probablemente ya sabrás, Apple diseña sus propios procesadores, pero existen algunos modelos que se basan en los Cortex de ARM afectados, que son los chips A4, A5, A5X y A6.

De esta forma, los siguientes dispositivos de Apple son potencialmente vulnerables:

  • iPhone 4 (chip A4)
  • iPhone 4S (chip A5)
  • iPhone 5 (chip A6)
  • iPhone 5C (chip A6)
  • iPad de 1ª generación (chip A4)
  • iPad 2 (chip A5)
  • iPad de 3ª generación (chip A5X)
  • Apple TV de 2ª generación (chip A4)
  • Apple TV de 3ª generación (chip A5)
  • iPod touch de 4ª generación (chip A4)
  • iPod touch de 5ª generación (chip A5)

A pesar de que los riesgos de esta nueva amenaza de seguridad no son muy altos dada la complejidad de llevar a cabo un ataque, suponemos la compañías afectadas lanzarán actualizaciones para corregir la vulnerabilidad. | Fuente: 9to5Mac